LenStarWeb Requirements
LenStarWeb requires Microsoft Internet Explorer 7.0 or higher. We recommend Microsoft Internet Explorer 7.0 or higher. AOL users require AOL 5.0 or higher. We recommend AOL 6.0 or higher.

To Download Internet Explorer: Click to download Microsoft Internet Explorer 5.5 or higher. Click Here


AOL Users Only: Click to download AOL 6.0 or higher. Click Here


Copyright © 2000 LenStar Inc., a subsidiary of London Bridge Group. All rights are reserved.
The data contained in this site is made available without warranty of any kind.